99% of Power in Spain has been restored by bringing national substations back online, restoring power & telecommunications systems.
Posted Apr 29, 2025 - 08:18 UTC
Update
We are continuing to investigate this issue.
Posted Apr 28, 2025 - 14:08 UTC
Investigating
We are currently monitoring ongoing energy supply issues across Spain, which started at about 11:30 GMT today and have been causing instability in various sectors, including telecommunications. While Direct Telecom’s core systems and networks are fully operational and supported by backup power solutions, localized power outages and energy restrictions may affect individual customer connectivity, particularly in mainland Spain. At this time, our services remain stable. However, customers who do have electricity may experience intermittent issues such as slower connections, brief service interruptions, or degraded call quality depending on local conditions.
Our engineering teams are in close coordination with national infrastructure providers to minimize any potential disruptions. We have enhanced monitoring and response protocols in place and will continue to update you if the situation changes.
This issue has also affected National Mobile operators, leaving clients unable to use the call service, but it seems 4G data is mostly intact enabling clients to communicate via WhatsApp.
We have been told the national power grid may take 6 to 10 hours before it is fully operational.
— Direct Telecom Support Team
Posted Apr 28, 2025 - 14:07 UTC
This incident affects: Fibre Optics Broadband - XFN, Fibre Optics Business Broadband, 4G Home Broadband, SkyWire Internet Broadband, and dT Media TV.