All Direct Telecom clients have had service restored in the Valencia region
Posted Nov 05, 2024 - 15:21 UTC
Update
Reports indicate that work is ongoing and lots of progress is being made every hour that goes by to re-establish communications for the users in the more severely affected areas.
Posted Oct 31, 2024 - 16:12 UTC
Update
We are continuing to investigate this issue.
Posted Oct 30, 2024 - 10:01 UTC
Investigating
Many communications systems have been damaged due to the DANA storm in Valencia affecting Fibre Optics lines as well as Mobile services since 29/10/24. Engineering teams are working hard to get all systems back online as soon as possible.
Posted Oct 30, 2024 - 10:00 UTC
This incident affects: Fibre Optics Broadband - XFN, Fibre Optics Business Broadband, 4G Home Broadband, SkyWire Internet Broadband, and dT Media TV.